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Format Conventions
In this document the following format conventions are used:
Menu items are given in a bold, Arial font.

Windows Applications

Keys that you press are enclosed in angle
brackets.

<Enter>

Feedback
If you notice any mistakes in this document please contact the Information Officer.
Email should be sent to the address info-officer@leeds.ac.uk
Copyright
This document is copyright University of Leeds. Permission to use material in this
document should be obtained from the Information Officer (email should be sent to
the address info-officer@leeds.ac.uk)
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1.0 Introduction
1.1 About Spreadsheet Software
Before spreadsheets became such widespread computer tools, calculations were done
either by hand or by writing programs with a programming language. This was timeconsuming and frequently led to errors in the calculations.
Spreadsheets very quickly took over the tasks from the hand calculation method and,
as time has gone on, they have taken on more and more of the calculations that used
to require programming languages.
The power of a spreadsheet lies in its ability to have formulae in cells. These
formulae can consist of numbers and simple arithmetic operators, mathematical,
statistical and financial functions and cell references. The result of a calculation in
one cell can be used in a further calculation. The concept is simple, but it means that
spreadsheets can perform very complicated analyses.
This set of exercises is designed to introduce you to the way Excel uses formulae and
functions. The document is not intended to give you a comprehensive list of all the
functions that Excel can perform as that can be obtained from the on-line Help
system. However, once you have completed these exercises you should be able to use
other Excel functions.

1.2 Prerequisites
It is assumed that you already know how to open, close, save and print an Excel
spreadsheet and that you know how to enter data, edit data and create simple
formulae. If you are new to Excel it will be necessary for you to read and work
through the following document before attempting these exercises:
Getting Started with Microsoft Excel 2002

(BEG 40)

If you wish to investigate some of the other facilities in Excel then the following
documents are also available:
Formatting Data in Microsoft Excel 2002

(TUT 48)

Using Charts with Microsoft Excel 2002

(TUT 49)

Data Manipulation with Microsoft Excel 2002

(TUT 130)

Before you begin, download the zip file for use with this document.
Open a web browser such as Internet Explorer and go to URL:
www.leeds.ac.uk/iss/documentation/tut/examples/index.html
Scroll down to Writing Formulae with Microsoft Excel 2002 and right-click on the
file TUT47.xls. Select Save Link As…(Save Target As… in Internet Explorer).
When the Save As dialog box appears, select a suitable directory and click Save.
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Task 1 Using Series
It is often necessary to create a regular, repeating series. Being able to do this
automatically can save a lot of time. Excel has some built-in series, e.g. days of the
week and weeks of the year. In addition to using these series, Excel can be made to
continue a pattern set by the user. The exercises in this section will illustrate the
various methods.
Activity 1.1

Run Excel (Start > Microsoft office XP > Excel) and open the file
that you have just saved – TUT47.xls. Click on Sheet 2, to start with a
completely blank worksheet.

Figure 1 The Worksheet Labels

Select cell A1 using the mouse. Type Jan and then press <Enter>.
The word Jan should appear in cell A1. Select cell A1 again and point
the mouse at the fill handle (as you do this the cursor will take the
shape of a cross hair). Drag the mouse down the column to cell A12
and then release it. Cells A1:A12 will now contain the months Jan to
Dec.

.
Figure 2 Fill Series Operation
Activity 1.2

Enter the word Monday in cell B1. Point to the fill handle and when
the cursor shape changes to a cross hair, drag the mouse down to cell
B7 and release it. The cells will be filled with the days of the week.
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Activity 1.3

It may be desirable to produce a list of weekdays only and Excel has
such a list. Enter Monday in cell C1 and repeat activity 1.2. This time
note that at the bottom right of the cell C7 is a symbol. Click on this to
see a Fill Series menu, and choose Fill Weekdays.

Figure 3 The Fill-Series Menu
Activity 1.4

Excel will also recognize a mixture of text and numbers as a potential
series. In cell D1 type Semester 1. Use the fill series handle and drag
the mouse to cell D3. Note that Excel has extended the series to
Semester 3.

Activity 1.5

Excel can create a series from two cells that contain the first two
(numeric or date) terms. It may be useful to have a list of dates a week
apart. In E1 type 1/9/04 and in E2 type 8/9/04. Highlight both cells
together and drag the fill handle down to E5.

Figure 4 User-Defined Date Series
Activity 1.6

Return to Sheet 1. In cell A5 type Jan, in cell A10 type Feb and in cell
A15 type Mar. In B5 type Week1 and then drag the fill handle to B8 to
complete the series. Copy the contents of cells B5:B8 into cells
B10:B13 and B15:B18.
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2.0 Formulae
Formulae have three basic components:
•

Values include numbers, text and dates

•

Cell references (a cell is the intersection of a row and column)

•

Operators
o Subtraction

the minus sign

-

o Negation

the minus sign

-

o Addition

the plus sign

+

o Multiplication

the asterisk

*

o Division

the forward slash

/

o Exponentiation

the caret

^

A formula in Excel must be preceded by an equals sign

=

2.1 Functions
The real power of Excel is seen in its range of predefined functions. These are
grouped into the following types:
•

Financial

•

Date & Time

•

Mathematical and Trigonometrical

•

Statistical

•

Lookup & Reference

•

Database

•

Text

•

Logical

•

Information.

The components of a function are:
•

The equals sign

•

The name of the function e.g. SUM or AVERAGE

•

The arguments (these are enclosed in parentheses, and if there is more than
one argument, they are separated by commas) e.g.
=SUM(A1:A5)
=SUM(A1:A5,B1:B5)
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2.2 Layers
Spreadsheets contain two layers – the stored layer and the displayed layer.
The stored layer contains just what you type in. All numbers are stored in the same
way, text is stored as simple ASCII characters and formulae are stored exactly as they
are typed in. The formula bar will always show what is in the stored layer.
The displayed layer is what you see on the worksheet. It shows the result of a
formula. The displayed layer can also include formatting features for numeric data,
such as the number of decimal places or currency symbol. Text formatting includes
font size, style and colour.
By default the worksheet shows you what is in the displayed layer. To change this
display to show the stored layer, select Tools > Options, choose the View Tab and
check the Formulas box.

Figure 5 The Options Dialog Box
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Task 2 Simple Calculations
Activity 2.1

Click on Sheet 1. The aim is to calculate the sum of the values in the
cells C5, C6, C7 and C8. Click in cell C9 and type an = sign. This tells
Excel that what follows is a formula. Type C5+C6+C7+C8 and then
press <Enter> or click on the Confirm button (the green tick on the
formula bar). The result will be 95.

Figure 6 The Confirm Button on the Formula Bar
Activity 2.2

Now select cell C5 and change the number to 20. Press <Enter>.
Immediately the result in cell C5 changes to 102 to reflect the change
in data. When you have verified this, change the cell contents back to
13.

Activity 2.3

The process of using formulae can be improved by making use of the
built-in functions. Instead of referring to each cell as we did in
previously, we can use the Excel SUM function. This requires as an
argument the range of cells. In this case the range is C5:C8 so the
formula we require is =SUM(C5:C8). Click in C9 and press the
<Delete> key to remove the current formula and then type in the new
one. The result will be 95 as expected.

Figure 7 The Formula Bar Showing the SUM Function
Activity 2.4

Delete the contents of C9 again. This time we will highlight the cells
that are to be added. Click on the formula bar and type =Sum( Now
drag the mouse over cells C5:C8 and note that Excel has entered the
range for you. Type in a closing bracket ) and then press <Enter>. The
result will be the same.

Figure 8 Editing on the Formula Bar
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Task 3 Copying Formulae
Activity 3.1

Now that we have created a formula to sum one column, we can copy
the formula across to other cells in the same way that we continued a
series in Task 1. Click on C9 again, and note that the formula bar
shows the Excel function that was used in the calculation. Point to the
bottom right-hand corner of the cell and make sure that the mouse
pointer is in the shape of a cross hair. Drag the mouse across the row
until the cell G9 and release it. Click on cell D9 and look at the
formula bar. Note that the cell references have been translated and they
now refer to column D. The entries in columns F and G will be zero as
there are no numbers in the cells above them at the moment.

Figure 9 Formula Bar
Activity 3.2

Select the cell C14, type =SUM(C10:C13) and the press <Enter>. Use
the same method as in the previous activity to copy the formula across
to G14.

Activity 3.3

Repeat this process to insert the totals in cells C19:G19. The March
figures should be as follows:

Figure 10 Part-Completed Sheet
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Task 4 Using Insert Function
Activity 4.1

Clicking the Insert Function button activates the function wizard,
which provides a list of Excel functions and gives information about
the arguments they require. Click in cell F5 and then click the Insert
Function button. Select the category Math & Trig, and then scroll
down the lower window until the SUM function becomes visible.

Figure 11 Insert Function Dialog Box
Activity 4.2

Click on the SUM function and then click <OK> to proceed to the next
step. If the range C5:E5 has not been entered automatically by Excel,
type it into the Number 1 Box and click <OK>. (If we wanted to sum
two ranges that were not contiguous, we could enter the cell references
for the second block into the Number 2 box. As we did this, a further
box would be added to the list, ready to accept the references for the
third block.)

Figure 12 SUM Function Arguments Dialog Box
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Activity 4.3

Point to the bottom right corner of the cell, and when the cursor shape
changes to a cross hair, drag the mouse down to cell F9. (An even
quicker way to do this is to double-click the mouse when it is in this
position.)

Activity 4.4

Repeat this process to enter the remaining data in column F.

2.3 Relative and Absolute Cell Addressing
In Task 3 we copied a formula to other cells, and the cell addresses that we used in the
original formula were translated automatically to give the correct results. This is
called relative cell addressing. Sometimes, however, this is not the way we want
Excel to work. We may want some of the cells to remain static, or absolute, while
others translate in the usual way. This task will illustrate the need for absolute cell
addressing.
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Task 5 Using Absolute Cell Addressing
Activity 5.1

Click on sheet 3 in cell I2. We wish to calculate the percentage that the
sales figures in January contribute to the total sales for the first quarter.
To do this, enter the formula as shown:

Figure 13 Percentage Calculation (Relative Cell Addressing)
Activity 5.2

Copy the formula down to cells I3 and I4 in the usual way. The result
will be a series of error messages which warn of division by zero.

Figure 14 Error Messages
Activity 5.3

Click in the cell I3 to see the cause of the problem. The formula here is
H3/H6*100. The cell address H5 has been translated, but H6 is an
empty cell (treated as zero). This is not the calculation that we
intended. Although the reference H2 should be relative, to work out
the other percentages we must continue to use the divisor 1450 in H5.
To make this cell address absolute it is necessary to write it as $H$5.
Edit the formula in I2 to =H2/$H$5*100 and copy the formula down.
The answer will now be correct.

Figure 15 Correct Result
Activity 5.4

Return to sheet 1 and enter the formulae to calculate the totals
including VAT.
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Task 6 Statistical Functions
Activity 6.1

Click in cell C13 on sheet 3 and then click on the Insert Function
button on the formula bar. From the dialog box select the category
Statistical, click on the function AVERAGE and then click <OK>.

Figure 16 Insert Function (Statistical)
Activity 6.2

At the next dialog box, use the mouse to highlight the cells that contain
the marks for maths and then click <OK>. The result will appear in
C13.

Figure 17 Completed Dialog Box
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Activity 6.3

Copy the formula across to insert the average marks for physics and
chemistry.

Activity 6.4

The range of marks is required for each subject. Excel does not have a
RANGE function, so it will be necessary to calculate the maximum
and minimum marks and then subtract one from the other to give the
range. In the statistical category you will find functions called MAX
and MIN. First enter the formulae to get these results for maths and
then copy the formulae across to insert the results for the other two
subjects. The results are shown below:

Figure 18 Exam Results

The formulae are shown below.

Figure 19 Formulae for Exam Results
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Task 7 Ranges
It can be useful to give a name to an array of cells. Once this has been done, the name
of the array can be used in the formula instead of the cell references.
Activity 7.1

On sheet 3, delete the average marks for the three subjects. We will
now give names to the blocks of cells.

Activity 7.2

Highlight the cells for maths (C2:C11) and then from the menu select
Insert > Name > Define. The dialog box that appears will show that
Excel has assumed that you wish to name the range using the column
heading. Since this assumption is correct, click on <OK>.

Figure 20 Define Name Dialog Box
Activity 7.3

Repeat this process to create names for the physics and chemistry
results.

Activity 7.4

In cell C13 type the formula = AVERAGE(maths) and press
<Return>. In D14 type the formula = AVERAGE(physics) and press
<Return>. In E14 type the formula = AVERAGE(chemistry) and
press <Return>. The results will be the same as the ones obtained
earlier.
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Task 8 Using an Array Formula
Activity 8.1

On sheet 1, scroll down to the range A23:G27. This is a table identical
to the three above, but this table will summarise the information from
the other three tables. First give names to the ranges as follows:
Jan
Feb
Mar

Activity 8.2

C5:E9
C10:E14
C15:E19

An array formula is entered into one cell but displays its results in a
range of cells. This range must be selected before the formula is
entered. Select the range C23:E26 using the mouse. Note that the cell
C23 is white on a black background because it is the active cell in
selected range. Now type =Jan+Feb+Mar
Hold the <Shift> key and the <Ctrl> key down together, and press
<Enter>. The highlighted range will fill with numbers. In the
formula bar the formula should have curly brackets around it to
indicate that it is an array formula.

Figure 21 Array Formula

Move the active box around the range using the cursor keys. You will
notice that the formula looks identical in every cell. In reality it is
only stored in cell C23.
This formula has added the three ranges together cell by cell according
to position. So, it has added:
C5+C10+C15 and displayed the result in C23
C6+C11+C16 and displayed the result in C24
D5+D10+D15 and displayed the result in D23
Note

Array formulae are necessary for certain functions that output a table
of results. The advantages in using them for repetitive calculations in
normal formulae are that they are quicker to type in, quicker to
calculate and they take up less storage space.
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Task 9

Finishing Excel

You should always quit any computer program when you have finished your session.
Never switch off the computer without closing down Windows. Do not leave a
computer whilst you are still logged on to it as others may use your account and could
damage your files.
Activity 9.1

Select File > Exit. Excel will prompt you to save your document
before it lets you quit. Click <Yes> to save the changes, <No> to quit
without saving the changes, or <Cancel> to return to the spreadsheet.

Figure 22 Quit Dialog Box

.
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